Jump to content
ARC Discussion Forums
Sign in to follow this  
salvador001

Testors Flat Clear Acrylic problem!

Recommended Posts

Hi Guys, ive recently started using the Testors Flat Clear Acrylic but hey, something is wrong, when i apply it its good, but when it dries ohh my god, it creates a white finish, what is wrong with it? can somebody help me with it?

Thanks.

Rod.

Share this post


Link to post
Share on other sites

You must be spraying too heavy a coat. You need to build up your coats slowly spraying light coats.

Rob

Share this post


Link to post
Share on other sites

Are you spraying it with an airbrush? If so, are you using a retarder?

Darryl

Well, both, airbrush and brush directly, i thin it with Testors Acryl thinner and water, ive seen that when i apply it in a surface where there is no gloss finish it creates this white thing, but when i apply it on top of the future or gloss coat the difference is considerable.

Thank all you guys for your comments.

Any other tip?

Rod.

Edited by salvador001

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...