Jump to content
ARC Discussion Forums

Sign in to follow this  
zaktwist

Finemolds Slave 1 (with lighting)

Recommended Posts

Hey all! Here's my Slave 1 almost done although still lots of touch ups and fettling to do. Really enjoyed this build despite nearly giving up due to melting the right wing shoulder-thing and having to rebuild it with milliput (hot fire + plastic = bad news!). I've used ref pics of actual studio model and attempted to emulate the chipping/colours etc as best as possible. I used custom mixed mr. color paints (finemolds colour suggestions are a imo incorrect)and oil paints and chalks for weathering.

DSC_0560.jpg

DSC_0561.jpg

DSC_0555.jpg

DSC_0554.jpg

With lights on (pics don't really do it justice imo)

DSC_0556.jpg

DSC_0562.jpg

DSC_0558.jpg

DSC_0567.jpg

DSC_0569.jpg

Still unsure about how to display model and whether or not to include Boba...

Thanks for looking!

Share this post


Link to post
Share on other sites

Very nice work - love the lights - is that something you made yourself?

Share this post


Link to post
Share on other sites

Beautiful job! How did you go about your chipping effects?

Hi and thanks nicholas! For the chipping I first painted on the darker green grey then used a latex masking fluid which I stippled on with a sponge and scraped some with a tooth pick to make it look less uniform, all the time studying ref pics! When dry, I sprayed over lighter grey/green then peeled off masks. It took a few attempts to get it right!

Share this post


Link to post
Share on other sites

Very nice work - love the lights - is that something you made yourself?

Hi and thank you! I didn't make the LED set up no. I brought an LED light kit from ebay, the seller made it to my specs and for a real low price, saved me a lot of hassle, http://www.ebay.co.uk/usr/bloater079?_trksid=p2053788.m1543.l2754 . I just glued the LEDS to the fibre optics id already installed, crammed it all in and its done.

Share this post


Link to post
Share on other sites

GORGEOUS! Really puts my Bubba-transport to shame!

Share this post


Link to post
Share on other sites

as the others have said before me - excellent paint job! Way better than what I would do for sure - mind you, have never tried the chipping technique (something I must do one day)

It is a lot bigger than I thought it would be - your hand provides excellent perspective

What I like best of all is the lighting - more over - it's relative size and brightness. It is in perfect scale to the ship and looks fantastic -not over done and not to bright. Brilliant!

I look forward to seeing some more of your builds. :cheers:

MH

Share this post


Link to post
Share on other sites

Thank you all for the kind words! Finally finished so here's some new photos

DSC_0571.jpg

DSC_0572.jpg

DSC_0573.jpg

DSC_0574.jpg

DSC_0575.jpg

DSC_0576.jpg

DSC_0577.jpg

DSC_0578.jpg

DSC_0581.jpg

DSC_0584.jpg

Thanks again and happy modelling! :salute:/>

Share this post


Link to post
Share on other sites

That is fantastic, and the lighting is spot-on. The paint job, perfect. Very nice!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...