Jump to content
ARC Discussion Forums
  • advertisement_alt
  • advertisement_alt
  • advertisement_alt
Sign in to follow this  
SERNAK

Security Issue with Arc Forums

Recommended Posts

Hi everyone,

 

Is there a security issue with Arc Forums? I'm asking this because every time I'm signing-in I don't see the typical "https" neither the locker icon.

Share this post


Link to post
Share on other sites

Why are you posting on a public forum if you're worried about the security? Everyone can already see what you are writing, why encrypt it?

Share this post


Link to post
Share on other sites

Using the https protocol would protect (encrypt) the interactions between your browser and the site.  As Dave notes, those interactions result in publicly readable content. The ISPs already know where you're going; what you've done is just a matter at looking at the site using the generally available and unrestricted tools.

Share this post


Link to post
Share on other sites

Thank you for your replies gents.

 

I have asked this because in other forums, when I sign-in I see the "https" and locker icon.

 

When being old and not internet literate, some things unexpectedly surprise you.

Share this post


Link to post
Share on other sites

Steve would have to modify the forum web site to enable enryption. I don't see the need as there aren't finacial transactions or exchange of personal data except what you feel comfortable providing in your profile.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...