Jump to content
ARC Discussion Forums
Kurt H.

*whining* Failed regulator

Recommended Posts

I was trying to track down an air leak in my compressor, a badger Million Aire.  It kept loosing pressure and running even if I was not using it. I sprayed soapy water on all the fittings but could not find the leak, so I took the regulator off and all the fittings, as well as the pressure gauge and added teflon tape (again) .

 

I put it back together and the regulator kept hissing and i could feel several places air was coming from it, and I could not control the pressure. What ever was wrong I must have done fatal damage. The tank also had quite a bit of water. 

 

I ordered a new regulator, but no airbrushing for a few days until it arrives. 😥

Share this post


Link to post
Share on other sites

The new regulator arrived, but I need to get a 1/8 to 1/4 fitting for my badger hose. I had to use the one that it came with to screw the regulator into my compressor. I was unable to remove the fittings from the regulator body so I could not swap them from my old regulator.

 

I can not get to a store until the middle of the night, so hopefully walmart has the fittings, otherwise i will need to wait to go to lowes

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×